• last updated 1 hour ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
All GSOC Rapps changes
All GSOC Rapps changes
There was no strong consensus on this so I'll leave it as is for now.

There was no strong consensus on this so I'll leave it as is for now.

Given that VS2010 is the newest one that has a chance to work in ReactOS, that may take a while.

Given that VS2010 is the newest one that has a chance to work in ReactOS, that may take a while.

Seems a bit ugly IMO. Edit: I'd really prefer using enum class if we switch to more modern MSVC.

Seems a bit ugly IMO.
Edit: I'd really prefer using enum class if we switch to more modern MSVC.

I prefer having dedicated headers for semantically different parts of code.

I prefer having dedicated headers for semantically different parts of code.

Yes, I'll do that as the enum above.

Yes, I'll do that as the enum above.

Yep seems like I was thinking of something else. Doing a quick search through our CMakeLists.txt files, it seems like we do this in quite a few places, so it's OK.

Yep seems like I was thinking of something else. Doing a quick search through our CMakeLists.txt files, it seems like we do this in quite a few places, so it's OK.

I haven't found a command like this.

I haven't found a command like this.

Its not like you create many instances of this class. It will be cleaner if these are not global variables.

Its not like you create many instances of this class. It will be cleaner if these are not global variables.

There's also of course the option of using a namespace.

There's also of course the option of using a namespace.

don't we have some "add_include_files" for this?

don't we have some "add_include_files" for this?

In that case it would be best to have some prefix, like LicenseType_OpenSource and so on, rather than "polluting" the global namespace with names such as "Min" or "None".

In that case it would be best to have some prefix, like LicenseType_OpenSource and so on, rather than "polluting" the global namespace with names such as "Min" or "None".

VS2010 doesn't support enum class scoped enums.

VS2010 doesn't support enum class scoped enums.

This class uses static cache for locale strings so they won't be generated for each object but instead be shared.

This class uses static cache for locale strings so they won't be generated for each object but instead be shared.

Yeah, it acts like a namespace yet.

Yeah, it acts like a namespace yet.

The idea is that CAvailableApps just caches the entries into memory. The DB update merely downloads all the files, so it doesn't need any non-static object members and can be called without such, w...

The idea is that CAvailableApps just caches the entries into memory. The DB update merely downloads all the files, so it doesn't need any non-static object members and can be called without such, while still having semantic connection to CAvailableApps. I did it this way to keep the existing EnumAvailableApplications code, which can be redesigned I guess.

Opps, that's a weird typo. No warning either.

Opps, that's a weird typo. No warning either.

For this one it doesn't matter.

For this one it doesn't matter.

I created these variables static to share them across objects as they don't change, but have to be loaded.

I created these variables static to share them across objects as they don't change, but have to be loaded.

I did that to have .h files in the generated .vssolution .

I did that to have .h files in the generated .vssolution .

I'm not sure this function merits its own file.

I'm not sure this function merits its own file.

This looks like a hack.

This looks like a hack.

This is another weird class.

This is another weird class.

SHGetFolderPathAndSubDir can append a subdir you want and with CSIDL_FLAG_CREATE flag it will create it as well.

SHGetFolderPathAndSubDir can append a subdir you want and with CSIDL_FLAG_CREATE flag it will create it as well.

This seemed better as a switch. There are more RTL languages than just Hebrew.

This seemed better as a switch. There are more RTL languages than just Hebrew.

These definitions belog to an .h file alongside a comment saing that they should really be in a header for the exports of cabinet.dll.

These definitions belog to an .h file alongside a comment saing that they should really be in a header for the exports of cabinet.dll.

There is no reason to have this as a global variable.

There is no reason to have this as a global variable.

What does ERF mean? And where is this struct used in the code?

What does ERF mean? And where is this struct used in the code?

Adding a small helper at the top of the file that takes an ATL::CStringW&, the hDlg and the control id would make it really nice.

Adding a small helper at the top of the file that takes an ATL::CStringW&, the hDlg and the control id would make it really nice.