Default Project

I dont see any code using this spinlock in the diff, is that because it is already existing code, or is that because the spinlock is not used?

I dont see any code using this spinlock in the diff, is that because it is already existing code, or is that because the spinlock is not used?

Code style.

Code style.

We don't need to decrement the HalpOutstandingScatterGatherCount here?

We don't need to decrement the HalpOutstandingScatterGatherCount here?

ASSERT(Element != ScatterGatherList->Elements)

ASSERT(Element != ScatterGatherList->Elements)

ROUND_UP

ROUND_UP

Would be nice not to use a magic value here? Maybe define something for it.

Would be nice not to use a magic value here?
Maybe define something for it.

Do it quick! Before life catches up to you and you buy a new computer, fall in love, escape an island, get a demanding job, buy a house, get married and such, because then, then the hurricanes will...

Do it quick! Before life catches up to you and you buy a new computer, fall in love, escape an island, get a demanding job, buy a house, get married and such, because then, then the hurricanes will start attacking and your mom will call you 10x per day and and and by the time it's all over you barely can breath let alone run reactos the 6781 times needed to test/develop this thing.

Mainly formatting / dprint pass while I read into this. More to follow

Mainly formatting / dprint pass while I read into this.
More to follow

ditto

ditto

This now lives in sdk/include, fixed tho.

This now lives in sdk/include, fixed tho.

What should we do if this fails? For now I just return this status.

What should we do if this fails?
For now I just return this status.

All GSOC Rapps changes
All GSOC Rapps changes
There was no strong consensus on this so I'll leave it as is for now.

There was no strong consensus on this so I'll leave it as is for now.

Given that VS2010 is the newest one that has a chance to work in ReactOS, that may take a while.

Given that VS2010 is the newest one that has a chance to work in ReactOS, that may take a while.

Seems a bit ugly IMO. Edit: I'd really prefer using enum class if we switch to more modern MSVC.

Seems a bit ugly IMO.
Edit: I'd really prefer using enum class if we switch to more modern MSVC.

I prefer having dedicated headers for semantically different parts of code.

I prefer having dedicated headers for semantically different parts of code.

Yes, I'll do that as the enum above.

Yes, I'll do that as the enum above.

Yep seems like I was thinking of something else. Doing a quick search through our CMakeLists.txt files, it seems like we do this in quite a few places, so it's OK.

Yep seems like I was thinking of something else. Doing a quick search through our CMakeLists.txt files, it seems like we do this in quite a few places, so it's OK.

I haven't found a command like this.

I haven't found a command like this.

Its not like you create many instances of this class. It will be cleaner if these are not global variables.

Its not like you create many instances of this class. It will be cleaner if these are not global variables.

There's also of course the option of using a namespace.

There's also of course the option of using a namespace.

don't we have some "add_include_files" for this?

don't we have some "add_include_files" for this?

In that case it would be best to have some prefix, like LicenseType_OpenSource and so on, rather than "polluting" the global namespace with names such as "Min" or "None".

In that case it would be best to have some prefix, like LicenseType_OpenSource and so on, rather than "polluting" the global namespace with names such as "Min" or "None".

VS2010 doesn't support enum class scoped enums.

VS2010 doesn't support enum class scoped enums.

This class uses static cache for locale strings so they won't be generated for each object but instead be shared.

This class uses static cache for locale strings so they won't be generated for each object but instead be shared.

Yeah, it acts like a namespace yet.

Yeah, it acts like a namespace yet.