Alexander Shaposhnikov

[RAPPS] Toggle toolbar captions on resize

- Implemented hiding toolbar captions when buttons are about to intersect with the searchbar

- Minor style changes

[RAPPS] Stopped GCC whining (fixed GCC build)
[ATL] Fixed atlcoll.h ignoring _ATL_NO_EXCEPTIONS
[ATL] CStringT fixes

- Added copy constructor and assignment from CSimpleStringT to CStringT

This fixed initialization while using `operator+` in GCC.

```CStringW s = a + b; ```

operator+ operators are defined for CSimpleStringT.

It worked in MSVC because it did implicit conversion of CSimpleStringT to PCXSTR which called appropriate CStringT constructor.

GCC doesn't do such conversions and triggers an error.

- Unified `operator=(CStringT, PCXSTR)` with the rest

[RAPPS] Moved cabinet.dll related definitions to separate header
[RAPPS] Replaced my @gmail.com email with @reactos,org one & Removed my copyright from rosui.h
[RAPPS] License header unification and minor style changes

- Unified & reformatted license headers according to https://www.reactos.org/wiki/Coding_Style

- Minor style changes

[RAPPS] CConfigParser cleanup

- removed `static` from strings declaration as pointed out by gadamopoulos

[RAPPS] Renamed CmdParser to UseCmdParameters
[RAPPS] resource.h: Added missing space
[RAPPS] Deleted installdlg.cpp as unused
[RAPPS] Settings Dialog changes

- replaced `static` with unnamed namespace (static in this context was deprecated in C++03)

- fixed `Choose Folder` dialog text not loading the first time (trivial)

All GSOC Rapps changes
All GSOC Rapps changes
[RAPPS] Replaced double ternary operators with one `if` for readability
[RAPPS] Library load fixup in crichedit.h
There was no strong consensus on this so I'll leave it as is for now.

There was no strong consensus on this so I'll leave it as is for now.

[RAPPS] Merged two Installed and Available enum values into one enum
[RAPPS] Complete renaming
[RAPPS] Amendment: undo renaming in loaddlg.cpp
[RAPPS] Formatting fixes

- CAvailableApplicationInfo: added m_ prefixes to members

- CAvailableApps: renamed EnumAvailableApplications to Enum

- Renamed LICENSE_TYPE enum to LicenseType and renamed enum values

- unattended.cpp: Added license header

[RAPPS] Removed unecessary `inline` in crichedit.h
[RAPPS] Fixed newline in de-DE.rc
Seems a bit ugly IMO. Edit: I'd really prefer using enum class if we switch to more modern MSVC.

Seems a bit ugly IMO.
Edit: I'd really prefer using enum class if we switch to more modern MSVC.

I prefer having dedicated headers for semantically different parts of code.

I prefer having dedicated headers for semantically different parts of code.

Yes, I'll do that as the enum above.

Yes, I'll do that as the enum above.

I haven't found a command like this.

I haven't found a command like this.