Sylvain Deverre

I think the variable name "EventData" here is misleading. I think there actually was a "EventData" in the disabled code, along with something that should be called "EventNotification" we use to reg...

I think the variable name "EventData" here is misleading. I think there actually was a "EventData" in the disabled code, along with something that should be called "EventNotification" we use to register the event notification.

Undefined behaviour if psfParent is NULL ?

Undefined behaviour if psfParent is NULL ?

This is prone to buffer overflows, it should contain the size of the buffer, not the size of the string.

This is prone to buffer overflows, it should contain the size of the buffer, not the size of the string.

Should we fail and return here if we can't bind to parent shellfolder instead of continuing here ?

Should we fail and return here if we can't bind to parent shellfolder instead of continuing here ?

Why 0 in case we don't have psfi became sizeof(temppfsi) ?

Why 0 in case we don't have psfi became sizeof(temppfsi) ?

shell32: Fix some bugs of SHGetFileInfoA/W function
shell32: Fix some bugs of SHGetFileInfoA/W function
  • More
  • CR-108
  • finished reviewing
Misconfigured editor, I'll fix it probably in the week-end https://code.reactos.org/static/olpro3/2static/images/wiki/icons/emoticons/tongue.gif (yeah I'm busy with life right now)

Misconfigured editor, I'll fix it probably in the week-end (yeah I'm busy with life right now)

Would returning a failure code be sufficient ? I fear a bogous index could be forged in userland (attacker, misbehaving app, etc) and we may want to fail gracefully instead (unless sanity checks I ...

Would returning a failure code be sufficient ? I fear a bogous index could be forged in userland (attacker, misbehaving app, etc) and we may want to fail gracefully instead (unless sanity checks I don't remember also occur before, in this case it's OK for asserting)

My bad, I didn't see the class it was belonging to in the diff view.

My bad, I didn't see the class it was belonging to in the diff view.

Is there any good reason to use MultiByteToWideChar instead of just doing a plain strlen ?

Is there any good reason to use MultiByteToWideChar instead of just doing a plain strlen ?